« Studio 2011 は桜とともに? - SDL 製品セミナー | トップページ | 20周年記念 JTF 翻訳祭 - ご報告 »

2010.12.10

MultiTerm - SP3 アップデート後のエラー

★★
SDL MultiTerm 2009 SP3 の修正パッチがリリースされています。

先日のエントリにミストラルさんからコメントをいただきました。私はまだ遭遇していないのですが、MultiTerm を SP3 にアップデートした後に、エラーが出ることがあるそうです(.NET Framework 関連らしいのですが、TMサーバーに接続できないとか、そんなことも言われる模様)。Proz.com にも同様の症状について何件か報告があります。

リンク: Update SP3 Trados Studio, error message Multiterm (SDL Trados support)

そして、ミストラルさんからご報告があったように、このスレッドの最後のほうに SDL Support からの返信があって、修正パッチが公開されているとのことです。そのページがこちら。

リンク: Resolving Server connection errors after installing SDL MultiTerm 2009 SP3 (+Cumulative Update 8/9)

もし、MultiTerm を SP3 にアップデートした後でなんらかの不具合がある場合には、こちらのパッチを当ててみるといいかもしれません。

ちなみに、正規ユーザーであれば SDL サイトで[My Account] にログインして[マイ ダウンロード]に進めば、公開されているパッチはダウンロードできるようになっているのですが、この修正パッチは(まだ)載っていません。もしかすると、マイナーパッチ扱いで、もう少しまとまったところでパッチとしてリリースするのかもしれませんが、症状としてはけっこう大きいのにこの程度の扱いというのは、ちょっと不親切です。

というわけで、SDL の中の人にも「見てます」と言われてしまった拙ブログの責任として :) ご報告しておきます。最後になりましたが、ミストラルさん、情報提供ありがとうざいました。

03:39 午後 Trados 機能 |

はてなブックマークに追加

トラックバック


この記事へのトラックバック一覧です: MultiTerm - SP3 アップデート後のエラー:

コメント

別トピとして掲載していただいて恐縮です。MultiTerm 2009 SP3単独で発生する問題なのでこれから被害者が増加する可能性が高いと思われ、親切かつ適切なご判断だと思います。

この問題に関する説明は、
マイ アカウント > マイ サポート > SDL ナレッジ ベース(Go)
でHot Topics に移動すると見ることができるのですが、慣れないと読む気がしないでしょうね。ちらっと読んだ限りでは、元はWindowsのバグであるという説明のようですが、それを言っては...(以下自粛)

投稿: | 2010/12/10 20:52:55

いえいえ。こちらこそ。知らなければそのままになるところでした。

> 元はWindowsのバグであるという説明のようですが、それを言っては

でも実際、.NET とか Java みたいな共通プラットフォームを利用していると、そっちの不具合がけっこう出るんだと思いますよ。開発者泣かせ。

投稿: baldhatter | 2010/12/11 19:12:21

今回の問題は、MultiTermのSP3へのバージョンアップで生じているので、件のOSのバグは既知のもので、従来は回避していたのではないかというのが残念なところですね。そう言い切るには、結構、面倒な検証手順を踏む必要がありますが。

翻訳からローカリゼーションへと手を広げる場合、このような互換性の検証を業務内容に含むか含まないかで、手間や必要なリソースがずいぶん違ってきます。今回の問題は、日本語版、英語版等のOSのロケールには関係しないようですが、以前ここで話題になった、某超大手IT企業のWebサイトのような例もありますから。

投稿: | 2010/12/12 11:47:00

野咲です。

baldhatter さん、ミストラルさん、情報ありがとうございます。


当方もエラーが発生しております。

Studio 2009 SP3 で、Studio 2009 SP2 のときから作業していたプロジェクトの
*.sdlxliff ファイルを [エディタ] 画面に開こうとすると、

情報「用語ベース '(用語ベース名)' に接続できなかったため、用語認識ではこの用語ベースを使用できません.」

とポップアップ画面が出てきて、OK をクリックすると、

警告「既定の用語ベース '(用語ベース名)' に接続できなかったため、用語認識は無効になっています.」

とポップアップ画面が出てきます。


[プロジェクト (P)] - [プロジェクトの設定 (S)] - [言語ペア] - [すべての言語ペア] - [用語ベース] の [用語ベース] カラムで (用語ベース名) の後に 赤丸バッテン が付いています。

ここで、[追加 (A)] をクリックすると、ミストラルさんと同じ 800736b1 のエラー コードでエラーの表示画面が英語でポップアップされます。


まだパッチを適用していませんが、[マイアカウント] に挙がってからにしようかな、と思案中です。

投稿: 野咲 aka sam | 2010/12/19 13:53:08

野咲様

経緯や症状を拝見する限り、私が遭遇したのと同じ問題のようなので、件のパッチで直る可能性が高いのではないかと思いますが、今の段階では、自己責任で試してみるしかありませんね。この問題が発生するとStudio 2009(SP3)ではMultiTermが使えないわけで、深刻度としては最高ランクに近いと思いますが、現時点では業務で2009を使用するケースはほとんどなく、SP3を当てたユーザーもまだ少ないので、今のところは大きな問題になっていないのだろうと思います。ユーザー環境によって発生する場合としない場合があるのかについてもはっきりしません。

システムのバックアップを使い慣れていらっしゃれば、万一、パッチを当てて問題が発生すれば、当てる以前に戻してしまえばいいのですが、実行するには結構、勇気が要ります(新しいPCを導入したら、業務で使用する前にバックアップソフトの動作確認を行わないと怖くて使えません)。サブシステムを用意し、そちらで安全性をじっくり確認してから業務システムに導入するのが最善ですが、そういう余裕はなかなか持てないのが実状です。

投稿: | 2010/12/28 14:18:46

野咲さん、ミストラルさん、コメント返信遅くなりました。あっと、年を越えましたので、遅ればせながら、今年もよろしくお願いいたします。

昨年最後のエントリで書いたように、2009を使うPCを移行したため、最近はあまり2009を開くことがないという状況です。もしかすると、近いうちに実際に業務で2009を使うケースに遭遇しそうなので、この問題のパッチが正式公開されないようであれば、SDL さんに聞いてみようと思います。

投稿: baldhatter | 2011/01/16 1:47:58

いまさらですが、こちらこそ今年もよろしくお願いします。

件のパッチですが、当てた後、MultTermとStudio2009SP3については連携の確認をしたのですが、Trados2007については特に動作確認はしませんでした。年明け早々、2007の案件を受注したので起動すると、2007のライセンスが消失していました(笑)。2009のライセンスは無事でした。パッチとライセンス消失の因果関係を証明できるわけではありませんが、パッチを当ててからTrados2007を起動するまでの数日間、ライセンスに関連するような操作は一切、していません。

人柱になってしまったようですが、件のパッチや1/22のエントリーにある累積アップデート(CU9)を当てる際には、安全のため、いったんライセンスを返却して保護しておいた方がいいと思います。

投稿: | 2011/01/22 21:42:52

コメントを書く

## コメントは承認制なので、公開されるまでに時間のかかることがあります。



(必須ではありません)